
Getting Started with the I/O Tool Kit 
 
This information will help guide you through system configuration. You may wish to review the SIXNET I/O Tool Kit 
Overview topics if you haven’t already done so. These topics also contain information that may be useful for users of 
the earlier SIXNET programs. 
 
Prior to following this outline, you should: 

z Install and wire your SIXNET I/O 
z make serial port connections 
z Configure your computer for Ethernet networking 

 
Then proceed with this outline. Note that some steps may not apply to all systems. These steps can be bypassed as 
needed. 

 
 
Follow the step numbers to configure and test your I/O.  
 

1) Create Station and Module Configurations 
2) Configure I/O Transfers Between Stations 
3) Configure Datalogging 
4) Select a Communication Port for Downloading 
5) Link SixTRAK Modules to Their Controller 
6) Load the Configuration into each Station or Module 
7) Test the I/O of each Station or Module 
8) Add Virtual Modules to your Station 
9) Access Your SIXNET I/O From Other Applications 
10) Export Tag Names to Other Applications 

 



Installing and Wiring SIXNET I/O 
 
Refer to the User Manuals on the SIXNET CD for mounting, wiring and installation guidelines. To access these 
documents, insert your SIXNET CD. From the Home page select the Documentation link. Then select the User 
Manuals link. Finally, select the User Manual for the product you are installing. These manuals are PDF files and will 
be displayed if you have Adobe Acrobat or some other pdf file viewer installed on your computer. If you don’t have a 
viewer installed, you can install the Adobe Acrobat reader from the SIXNET CD. A link to the Acrobat Reader 
installation is provided just above the User Manuals list.  
 
I/O channel wiring diagrams are provided in the PDF files and are also provided in the SIXNET Product Catalog, 
which is part of this help system. 
 
Module Jumpers: 
Some SIXNET I/O modules have movable jumpers inside their base assemblies. Some modules that have jumpers are: 

 
· All instrumentation analog input modules 
· SixTRAK and RemoteTRAK 8 channel 4-20 mA analog input modules 
· EtherTRAK discrete inputs 
· SixTRAK and EtherTRAK RTD input modules 
· EtherTRAK, RemoteTRAK and SixTRAK combination I/O modules with analog inputs 

 
Refer to the appropriate User Manual to determine the proper setting of each jumper. The jumpers are accessible by 
removing the plug-in logic module and opening the access door in the base. 
 
 
Configure your Computer for Ethernet Networking 
 
If you will be using Ethernet to communicate with your I/O, then the TCP/IP protocol will need to be installed and 
configured properly on your computer for communication to be successful. Refer to Getting Started with Ethernet 
Networking for details on Ethernet configuration. 
 
SIXNET I/O supports most standard Ethernet network media. You can use Ethernet switches and hubs as needed to add 
Ethernet I/O to your network. 
 
 
Serial Port Wiring 
 
Make serial port connections as needed. Several types of serial cables may be needed for your system. Here is a 
summary of the most common cables and their usage: 
 
RJ45 to DB9 
Most newer SIXNET controllers have RJ45-style connectors for their serial port(s). These include all IPm-based 
controllers (VT-IPM, VT-MIPM, ST-IPM, ST-GT-1210 and ET-GT-ST-3), SiteTRAK RTUs and the Ethernet I/O 
Expander (ET-GT-ST-2). Plug the supplied RJ45 to DB9 female adapter onto the DB9-style RS232 port on a computer 
or SIXNET station. Then connect a straight-through Ethernet cable between the RJ45 to DB9 female adapter and one of 
the RJ45 serial ports on the SIXNET controller. 
 
ST-CABLE-PF  
Most legacy SIXNET controllers and the RM-232-SETUP module (used for configuring RemoteTRAK and 
EtherTRAK I/O) have DB9-style connectors for their serial port(s). Connect the ST-CABLE-PF between your 
computer and the DB9-style serial port on the SIXNET controller or setup module. 
 
VT-CABLE-MDM 
This cable is used to connect a SIXNET Industrial Modem (VT-MODEM-###) to a DB9-style RS232 port on a 
computer or legacy SIXNET station. For newer SIXNET controllers with RJ45-style connectors, a RJ45 to DB9M 
adapter is usually provided. Use the adapter and a straight-thru Ethernet cable in place of the VT-CABLE-MDM. Refer 
to the “RS232 Port Wiring” link below for more information. 
 



Step 1: Creating Station and Module Configurations 
 
Use the I/O Tool Kit to create a configuration for each SIXNET station and I/O module in your system. The easiest way 
to do this is to use the Plug and Play Wizard. Start the Plug and Play Wizard and select “Add a new station to the 
project”. Select the appropriate product line from the Select New Station Type window. Next, you’ll be prompted for a 
name for the project file. After you assign a project name, fill in each configuration window set that appears for the 
station or module. You can edit these windows at a later time, so it is not necessary at this time to fill in all fields. 
 
The station and I/O module configurations should be created in the following order: 
 
IPm stations (VT-IPM, ST-IPM) and SixTRAK I/O modules – Click here for suggestions. 
Mini-VersaTRAK mIPm RTU – Click here for suggestions. 
SixTRAK I/O controller (ST-GT-1210) and SixTRAK I/O modules – Click here for suggestions. 
I/O concentrators (ET-GT-ST-2, -1) – Click here for suggestions. 
Dual Ethernet I/O gateway (ET-GT-ST-3) and SixTRAK I/O modules – Click here for suggestions. 
VersaTRAK or Mini-VersaTRAK RTUs and SixTRAK I/O modules– Click here for suggestions. 
Legacy SixTRAK gateways and SixTRAK I/O modules – Click here for suggestions. 
EtherTRAK and RemoteTRAK I/O modules – Click here for suggestions. 
Ethernet gateways (ET-GT-232, -485) – Click here for suggestions. 
 
 
Configuring IPm Stations and I/O Modules 
 
Configure each IPm-based controller (ST-IPM, VT-IPM, VT-MIPM, ST-GT-1210 or ET-GT-ST-3) and its attached 
SixTRAK I/O modules, if any. The IPm configuration should include a unique station name and number, the serial 
number (see the note below) as it is written on the station, the correct memory and communication port options, 
communication port settings and a definition of each SixTRAK I/O module. The IPm configuration can also include 
virtual I/O modules and I/O Transfers, though it is often easier to go back and add them after the remaining station and 
module configurations have been created. 
 
If you have a license for the SCS feature set of the I/O Tool Kit, you can access the Files to Load tab of the IPm 
Configuration window and reference all of the applicable files for the particular IPm station (all except ET-GT-ST-3). 
Then you can use the Load all Now (Predefined Files) command to load all of those files in one operation. 
 
A Note about entering serial numbers: 
 
Whenever possible, it is recommended that you enter the IPm controller’s serial number into the I/O Tool Kit. However, 
it is possible to load and maintain an IPm controller if the serial number field is left blank or contains a serial number 
does not match the serial number written on the controller. While this capability is very flexible, there are potential 
risks if more than one IPm controller exists on an Ethernet network or party line serial communication media such as 
radio modems. Without a serial number, the I/O Tool Kit may need to send special broadcast messages that any IPm 
station would respond to. It would be possible to load a different IPm station than the one intended. If it is not possible 
or practical to enter the IPm controller’s serial number, then it is recommended that the Ethernet or serial 
communication be isolated such that only the intended IPm controller would receive commands from the I/O Tool Kit. 
 
If the IPm controller’s serial number is entered into the project file, there will be no risk of errant loading because the 
IPm controller’s serial number will be embedded in all outgoing commands. Broadcast messages will not be used and 
only the correct IPm controller will accept the commands. 
 
 
Configuring the SixTRAK I/O Controller and I/O Modules 
 
Configure each SixTRAK I/O Controller (ST-GT-1210) and its attached SixTRAK I/O modules, if any. The I/O 
Controller configuration should include a unique station name and number, the serial number as it is written on the 
station, the correct memory and communication port options, communication port settings and a definition of each 
SixTRAK I/O module. The I/O Controller configuration can also include virtual I/O modules and I/O Transfers, though 
it is often easier to go back and add them after the remaining station and module configurations have been created.   
 
A Note about entering serial numbers: 
 
Whenever possible, it is recommended that you enter the I/O Controller’s serial number into the I/O Tool Kit. However, 
it is possible to load and maintain an I/O Controller if the serial number field is left blank or contains a serial number 



does not match the serial number written on the I/O Controller. While this capability is very flexible, there are potential 
risks if more than one I/O Controller exists on an Ethernet network or party line serial communication media such as 
radio modems. Without a serial number, the I/O Tool Kit may need to send special broadcast messages that any I/O 
Controller would respond to. It would be possible to load a different I/O Controller than the one intended. If it is not 
possible or practical to enter the I/O Controller’s serial number, then it is recommended that the Ethernet or serial 
communication be isolated such that only the intended I/O Controller would receive commands from the I/O Tool Kit. 
 
If the I/O Controller’s serial number is entered into the project file, there will be no risk of errant loading because the 
serial number will be embedded in all outgoing commands. Broadcast messages will not be used and only the correct 
I/O Controller will accept the commands. 
 
 
Configuring Legacy SixTRAK gateways and I/O Modules 
 
Configure each SixTRAK gateway (ST-GT-xxx-xxx) and its attached SixTRAK I/O modules, if any. The gateway 
configuration should include a unique station name and number, the correct memory and communication port options, 
communication port settings and a definition of each SixTRAK I/O module. The gateway configuration can also 
include virtual I/O modules and I/O Transfers, though it is often easier to go back and add them after the remaining 
station and module configurations have been created.   
 
 
Configuring VersaTRAK RTUs and I/O Modules 
 
Configure each VersaTRAK or Mini-VersaTRAK RTU and its attached SixTRAK I/O modules, if any. The RTU 
configuration should include a unique station name and number, the correct memory and communication port options, 
communication port settings and a definition of each SixTRAK I/O module. The RTU configuration can include virtual 
I/O modules and I/O Transfers, though it is often easier to go back and add them after the remaining station and module 
configurations have been created.   
 
 
Configuring the ET-GT-ST-# and I/O Modules 
 
Configure each I/O concentrator (ET-GT-ST-2) or Ethernet I/O Expander (ET-GT-ST-1) and its attached SixTRAK I/O 
modules, if any. The configuration should include a unique station name and number, the correct communication port 
settings and a definition of each SixTRAK I/O module. The configuration can include virtual I/O modules and I/O 
Transfers, though it is often easier to go back and add them after the remaining station and module configurations have 
been created. 
 
 
Configuring Ethernet Gateways 
 
Configure each Ethernet gateway (ET-GT-232 or ET-GT-485) in your system. For each gateway, assign a unique station 
name and station number. Enter the serial number that is written on the gateway’s base. Assign a unique IP address and 
configure the RS232 or RS485 port settings as required for your system. Select the appropriate protocol for the serial 
port. 
 
A Note about entering serial numbers: 
 
Whenever possible, it is recommended that you enter each Ethernet gateway’s serial number into the I/O Tool Kit. 
However, it is possible to load and maintain an Ethernet gateway if the serial number field is left blank or contains a 
serial number does not match the serial number written on the Ethernet gateway. While this capability is very flexible, 
there are potential risks if more than one Ethernet gateway exists on an Ethernet network or party line serial 
communication media such as RS485 or radio modems. Without a serial number, the I/O Tool Kit may need to send 
special broadcast messages that any Ethernet gateway would respond to. It would be possible to load a different 
Ethernet gateway than the one intended. If it is not possible or practical to enter the Ethernet gateway’s serial number, 
then it is recommended that you isolate the Ethernet or serial communication such that only the intended Ethernet 
gateway would receive commands from the I/O Tool Kit. 
 
If the Ethernet gateway’s serial number is entered into the project file, there will be no risk of errant loading because 
the serial number will be embedded in all outgoing commands. Broadcast messages will not be used and only the 
correct Ethernet gateway will accept the commands. 
 



 
Configuring EtherTRAK and RemoteTRAK I/O Modules 
 
Configure each EtherTRAK and RemoteTRAK I/O module in your system. For each module, assign a unique station 
name and station number. Enter the serial number that is written on the module’s base. Assign a unique IP address to 
each EtherTRAK module. Configure the RS485 port settings as required for your system. 
 
A Note about entering serial numbers: 
Whenever possible, it is recommended that you enter each I/O module’s serial number into the I/O Tool Kit. However, 
it is possible to load and maintain an I/O module if the serial number field is left blank or contains a serial number does 
not match the serial number written on the I/O module. While this capability is very flexible, there are potential risks if 
more than one I/O module exists on an Ethernet network or party line serial communication media such as RS485 or 
radio modems. Without a serial number, the I/O Tool Kit may need to send special broadcast messages that any I/O 
module would respond to. It would be possible to load a different I/O module than the one intended. If it is not possible 
or practical to enter the I/O module’s serial number, then it is recommended that you use an RS232 setup module or 
isolate the Ethernet or serial communication such that only the intended I/O module would receive commands from the 
I/O Tool Kit. 
 
If the I/O module’s serial number is entered into the project file, there will be no risk of errant loading because the 
serial number will be embedded in all outgoing commands. Broadcast messages will not be used and only the correct 
I/O module will accept the commands. 
 
 
 
Using the Plug and Play Wizard 
 

 
 
The Plug and Play Wizard makes it easy to add station and I/O module configurations to a new project file. 
 
Follow the instructions in the Plug and Play Wizard windows as they appear. When installing a new system, use the 
Wizard to add stations and I/O modules to a new or existing configuration. The configurations you create can be edited 
at a later time from within the I/O Tool Kit. 
 
To make changes: 
· Click anywhere in the line containing data or settings for the station or module. Then right-click and select 
“Configure” from the popup menu. A configuration window will be presented with the necessary tabs so you can select 
different views and make changes as needed. 
 
 
Saving Your Project File 
 
After configuring your I/O, the next step is to assign a project name to store the configuration data into. Select the File 
-> Save As command or toolbar button. 
 
The project file name is assigned or selected from within the File Save As window. 
 
 



Step 2: Configuring I/O Transfers Between Stations 
 
An ET-GT-ST-1, -2 or –3 or any SIXNET programmable station has the ability to act as a master station that exchanges 
I/O registers with other SIXNET stations, EtherTRAK and RemoteTRAK I/O modules, and Modbus-compatible 
devices. This is accomplished by configuring I/O Transfers in the master station. This can be done in the Plug and Play 
Wizard or through the I/O Transfers view of the configuration window for the station. I/O transfers can be added and 
edited at any time. The transfers will begin within a few seconds of loading the configuration into the master station. 
 
See Also: I/O Transfers Overview 

 
 
 
 



Step 3: Configuring Datalogging in a Station 
 
Any programmable SIXNET station or a SiteTRAK RTU can be configured to perform datalogging. Select Configure 
-> Datalogging (Sixlog) to create a new datalog configuration. After you create the datalog configuration, select 
Operations -> Datalogging (Sixlog) -> Load Configuration to Station. Datalogging will begin a few seconds after the 
load. 
 
See Also: Datalogging Overview 
 
Load the Configuration into the Station or Module 
 
 



Step 4: Set the Host's Communication Parameters 
 
Click on the “Select …” command from the Device menu. Then configure the appropriate communication port from 
the Select Communications Device window. These are the settings your computer will use to communicate with the 
I/O. 
 
Select "Use Com Port" if you will be using a serial port of your computer to talk to the I/O. In the Com Port field, 
select the appropriate serial port of your computer. Then choose one of the following: 
  
· Choose settings in the Com Port area of the window that match the settings of the station. The default settings for 
most SIXNET serial ports are 9600 baud, 8 data bits, no parity and one stop bit.  
 
· Click the "Restore Defaults" button if you will be using the RM-232-SETUP module to load a configuration into 
the base of an EtherTRAK or RemoteTRAK module. 
 
Select "Use Ethernet Port" if you will be using the Ethernet card in your computer to load Ethernet I/O or a station with 
an Ethernet port.  
 
 



Step 5: Linking SIXTRAK I/O Modules 
 
Each SixTRAK I/O module needs to be "linked" to its controller. The linking process associates each SixTRAK 
module with its corresponding configuration settings in the controller. (These settings were originally defined in the 
project file.) Once a SixTRAK I/O module is linked and the configuration is loaded into the controller, the SixTRAK 
module’s Status LED will be ON solid instead of blinking. 
 
New Automatic Linking Feature for all IPm, ST-GT-1210 and ET-GT-ST-3 Controllers 
 
If your IPm-based controller has SixTRAK I/O modules connected to its ST-Bus, all or some of the modules may be 
linked automatically when you load your configuration into the controller. Here are some highlights of this new feature: 
 
· Once a module is linked, its Status LED will be ON solid. The Status LED will be blinking on modules that are 
not linked. 
 
· Each unique module (only one of its type exists on the ST-Bus) will be linked automatically when the 
configuration is loaded into the controller. 
· If multiple modules of a given module type exist, they will need to be linked manually the first time. However, 
once they are linked, they will link automatically from that point forward, even if the controller is replaced for any 
reason. 
 
During the load of your configuration, the I/O Tool Kit will present the Link window if any SixTRAK I/O modules 
have not been automatically linked. If you see this window, proceed with Manual Linking of SixTRAK I/O Modules. 
 



Step 6: Load the Configuration into the Station or Module 
 
Loading RemoteTRAK and EtherTRAK I/O Modules 
EtherTRAK and RemoteTRAK I/O modules are most easily loaded the first time using a field setup module 
(RM-232-SETUP). Subsequent loads can be performed through the Ethernet port or RS485 port. Simply connect your 
module(s) to the appropriate port of your computer. Select the appropriate communication device and then select the 
Operations -> Load Now command or toolbar button. 
 
See Also: 
Using the RM-232-SETUP Module with EtherTRAK and RemoteTRAK I/O 
Loading EtherTRAK I/O Without Using a Setup Module 
Loading RemoteTRAK I/O Without Using a Setup Module 
Loading RemoteTRAK I/O Modules Connected to an EtherTRAK I/O Module 
Loading RemoteTRAK I/O Modules Connected to an Ethernet Gateway 
 
Loading IPm-based Stations 
Each SixTRAK IPm, VersaTRAK IPm, Mini-VersaTRAK mIPm, ST-GT-1210 I/O controller or ET-GT-ST-3 can be 
loaded through its primary Ethernet port or serial port. The default IP address is 10.1.0.1 and the default serial port 
settings are typically 9600, 8, N, 1. 
 
Loading SixTRAK, VersaTRAK and Ethernet Gateways 
Each SixTRAK gateway, VersaTRAK RTU or Ethernet I/O concentrator should initially be loaded through its Plant 
Floor port. Subsequent loads can be performed through the Ethernet port (if populated) or through any serial port 
configured to recognize SIXNET protocol. 
 
Connect a Plant Floor RS232 cable between your computer and the Plant Floor port of the station. Select the 
appropriate communication device. In the main window, click in any one of the configuration fields for the station to be 
loaded and then select the Operations -> Load Now command or toolbar button. This will write the configuration data 
into the station.  
 
 
Using the RM-232-SETUP Module with EtherTRAK and RemoteTRAK I/O 
 
Insert the RM-232-SETUP into the base of the module being configured. Removal of the existing module and insertion 
of the field setup module can be performed even when power is applied. In the Device Selection window (select Device 
-> Select ..) choose “Use COM Port” and click the “Use Setup Mod. Settings” button. Also choose the appropriate 
COM port (COM 1, COM 2 etc..) from the dropdown list. In the main window, click in any one of the configuration 
fields for the module to be loaded and select the Operations -> Load Now command or toolbar button. This will write 
the configuration data into the base of the module. 
 
 
Loading EtherTRAK I/O Without Using a Setup Module 
 
This information applies to an EtherTRAK module connected directly to the computer using a crosswired cable, or 
through a hub or switch using a straight-through cable. 
 
In the Device Selection window (click Device -> Select...) choose “Use Ethernet” and choose “Single Station” for the 
Connection. In the main window, click in any one of the configuration fields for the module to be loaded and select the 
Operations -> Load Now command or toolbar button. This will write the configuration data into the base of the module.  
 
Notes: 
 
· The computer’s IP address and the IP address you are attempting to load into the EtherTRAK module must be on 
a compatible subnet in order for the module loading to work. For example, if you are attempting to load an IP address 
of 10.1.0.1 into the EtherTRAK module, your computer’s Ethernet card must be configured with a fixed IP address 
such as 10.1.0.9 and a subnet mask such as 255.255.255.0.  
 
· The initial loading of an EtherTRAK module over Ethernet may utilize a broadcast IP address in the message. 
Though highly unlikely, this type of message could interfere with other traffic on your Ethernet network during the 
loading of the module. The use of a setup module (RM-232-SETUP) is recommended if any brief interruption of 
Ethernet traffic is undesirable. If the EtherTRAK module has been previously configured with a proper IP address, then 



broadcast messaging will not be used.  
 
· The “Network / Passthru” setting will not use broadcast messaging as long as the EtherTRAK module’s serial 
number has been entered into the configuration. This mode can be selected after all EtherTRAK modules have been 
loaded with acceptable IP addresses. All outgoing messages for a given module will be sent using the appropriate IP 
address and destination station number for that module.  
 
 
Loading RemoteTRAK I/O Without Using a Setup Module 
 
This information applies to RemoteTRAK modules connected to the computer using an RS232 to RS485 converter, 
such as the RM-232-485-4U. 
 
Loading new (not previously configured) RemoteTRAK modules: 
Important: If any of your RemoteTRAK modules have not yet been configured, unplug or power down all 
RemoteTRAK modules except the one you will be configuring. 
 
In the Device Selection window (select Device -> Select ..) choose “Use COM Port” and choose “Single Station” for 
the Connection. Choose the appropriate COM port (COM 1, COM 2 etc..) from the dropdown list. In the main window, 
click in any one of the configuration fields for the module to be loaded and select the Operations -> Load Now 
command or toolbar button. This will write the configuration data into the base of the module. 
 
 
Loading previously configured RemoteTRAK modules: 
Note: It is not necessary to unplug or power down RemoteTRAK modules if they have all been previously configured 
with unique station numbers. 
 
In the Device Selection window (select Device -> Select ..) choose “Use COM Port” and choose “Network / Passthru” 
for the Connection. Choose the appropriate COM port (COM 1, COM 2 etc..) from the dropdown list. In the main 
window, click in any one of the configuration fields for the module to be loaded and select the Operations -> Load Now 
command or toolbar button. This will write the configuration data into the base of the module.  
 
 
Loading RemoteTRAK I/O Connected to an Ethernet Module or Gateway 
 
This information applies to loading RemoteTRAK module(s)s connected to the RS485 port of an EtherTRAK I/O 
module or ET-GT-485 Ethernet gateway. Here are the requirements and limitations of this capability: 
 
· This setup will only work with SIXNET protocol. If you are using Modbus protocol, you’ll need to use the 
RM-232-SETUP module to configure the RemoteTRAK module(s). 
 
· The Ethernet gateway / EtherTRAK I/O module must be configured and loaded for SIXNET passthru at 9600 
baud for the RS485 port setting. 
 
· The Ethernet gateway / EtherTRAK I/O module must be configured and loaded for a station number other than 
“1”. 
 
· The RemoteTRAK module(s) must be at their factory default setting (SIXNET protocol and 9600 baud). 
 
Here are the steps to follow: 
 
1. In your I/O Tool Kit configuration, each RemoteTRAK module and EtherTRAK module or ET-GT-485 gateway 
must be given a unique station number. The RemoteTRAK module(s) must be “Connected To:” the EtherTRAK I/O 
module or ET- 
GT-485 gateway. In the Device menu, select Network / Passthru as the Connection type. 
 
2. Configure the RS485 port of the EtherTRAK I/O module or ET-GT-485 gateway for SIXNET passthru at 9600 
baud, as opposed to the default 38,400 baud. Load the configuration into the EtherTRAK module or Ethernet gateway. 
Refer to Loading EtherTRAK I/O Without Using a Setup Module for more details. 
 
3. You should now be able to load each of your RemoteTRAK I/O modules by clicking anywhere in it’s 



configuration line in the I/O Tool Kit main window and selecting Operations ->Load ->Load Now or clicking the Load 
button. 
 
Increasing the Passthru Baud Rate 
 
You can generally run the RS485 passthru communications as fast as 38,400 baud. To do this, change the RS485 port 
configuration of each RemoteTRAK module to 38,400 baud, and reload each RemoteTRAK module. Then, reconfigure 
the EtherTRAK module or ET-GT-485 gateway’s RS485 port for 38,400 baud and reload the EtherTRAK module or 
ET-GT-485 gateway. 
 



Step 7:  Test I/O 
 
The Test I/O window can be used to verify the functionality of I/O in gateways, RTUs, I/O modules and the Control 
Room IOmap. I/O that can be read or written includes: 
 

· Physical discrete and analog I/O 
· Virtual discrete, analog, floating point and long I/O. 
· Counter inputs 

 
The Test I/O window can display and/or control all I/O at the station or module and at the station or module’s 
equivalent IOmap registers. It can also be used to write values to virtual inputs and physical / virtual outputs for the 
purpose of debugging standalone control programs. Tabs in the Test I/O window let you select the specific type of I/O 
to read and/or write. Multiple Test I/O windows can be opened as needed. 
 
I/O values can be displayed in Scaled, Decimal, Signal, or Percentage format as applicable. A Large window display is 
available for easy viewing of any single I/O channel from a distance. This view is particularly useful when making 
adjustments to field devices. 
 
 
How to Open Test I/O windows 
 
· To test the I/O of a gateway or RTU, simply click your right mouse button when you have the desired gateway / 
RTU highlighted and select “Test I/O” from the popup menu that appears. If you select “Direct to Selected 
Station/Module”, the Test I/O window will communicate directly to the station or module. If you select “Selected 
Station/Module in Active IOmap”, the Test I/O window will communicate with the active IOmap in your computer’s 
memory. Note that an IOmap must be running for this command to be available. The Status Bar at the bottom of the 
Test I/O window will indicate “Active IOmap”, or “Online” (with blinking LEDs) when communicating directly to the 
station. 
 
· To test the I/O of a specific I/O module, click your right mouse button when you have the desired I/O module 
highlighted in the Tree View, and select “Test I/O” from the popup menu that appears. If you select “Selected 
Station/Module in Active IOmap”, the Test I/O window will communicate with the active IOmap in your computer’s 
memory. Note that an IOmap must be running for this command to be available. The Status Bar at the bottom of the 
Test I/O window will indicate “Active IOmap”, or “Online” (with blinking LEDs) when communicating directly to the 
station. 
 
You can open multiple Test I/O windows simultaneously, as needed. 
 
A Test I/O window can also be opened by highlighting the desired gateway / RTU / module and then clicking on the 
Test I/O icon in the toolbar, or by selecting one of the two Test I/O choices from the Operations menu. The toolbar 
button will open a Test I/O window that communicates directly to the station or module. 
 
 
How to Use a Test I/O window 
 
When you open a Test I/O window, one I/O type will be displayed. Tabs are provided in the window so you can switch 
to a different I/O type. As an alternative you can open multiple Test I/O windows, each displaying the desired I/O type. 
 
I/O values can be displayed in Scaled, Decimal, Signal, or Percentage format as applicable. A Large window display is 
available for easy viewing of any single I/O channel from a distance. This view is particularly useful when making 
adjustments to field devices. 
 
The current status of physical and virtual inputs will be displayed. Virtual inputs can be written to by selecting the 
channel and then using the toolbar buttons to enter a new value. Note that the toolbar buttons will not be displayed if a 
physical input is highlighted. Only virtual inputs can be written to. 
 
The status of physical and virtual outputs will be displayed. An output can be written to by selecting the channel and 
then using the toolbar buttons to enter a new value. Discrete outputs can also be written to by double clicking in the I/O 
Value field. Other types of outputs can also be written to by clicking in the I/O Value field and typing in a new value. 
 
I/O Status messages for discrete I/O will be displayed automatically if they exist in the project file.  



Step 8: Adding Virtual Modules to a Station 
 
You can add Virtual I/O modules to a programmable SIXNET station at any time. These modules are used to hold I/O 
values from an ISaGRAF program or from I/O Transfers. 
 
Note: If you add virtual I/O modules to a station configuration, be sure to reload the configuration into the station.  
 
 
Virtual I/O Modules 
 
Virtual I/O modules are menu item modules that can be included in your I/O Tool Kit configuration. The virtual module 
types are: 

· Discrete Inputs 
· Discrete Outputs  
· Analog Inputs  
· Analog Outputs 
· Floating Inputs  
· Floating Outputs  
· Long Inputs  
· Long Outputs 
· I/O Module Status 
· Station Status 

 
These non-physical modules allow you to define and use I/O registers that are not associated with your physical (actual) 
SixTRAK I/O modules. Applications for these modules’ virtual I/O registers include: 
 

· to hold I/O data transferred from another station through an I/O Transfer, Control Room register update or 
Modbus data transfer 

· to hold output data written from an ISaGRAF program running in the gateway / RTU 
· these registers can be used as transfer locations in advanced I/O mapping schemes 
· To monitor I/O module and/or remote station status from within Windows applications 

 
Here are some tips on using virtual registers: 
 

· Virtual I/O modules can be inserted (or deleted) and assigned module tag names using the I/O Tool Kit 
program. (Note that virtual modules are not included in the Bill of Materials since there is no cost 
involved.) 

· I/O tag names can be assigned to virtual I/O in the I/O Tool Kit program. 
· Virtual I/O registers can be viewed or altered using the Test I/O window in the I/O Tool Kit. 

 



Step 9: How to Access SIXNET I/O From Windows Applications 
 
Any of the following methods may be used to access SIXNET I/O from other applications: 
 
Standard I/O Drivers 
Citect HMI software includes an I/O driver (SxDirect) that communicates directly to SIXNET stations and I/O modules. 
The optional SCS feature set of the SIXNET I/O Tool Kit includes an exporting function that automatically configures 
the Citect SxDirect driver and also creates Variable tag records for the SIXNET I/O. 
 
 
Standard Modbus Drivers 
Modbus Ethernet and serial drivers have been incorporated into a number of SCADA, control and MMI packages. 
SIXNET IPm stations, SixTRAK gateways, VersaTRAK RTUs, RemoteTRAK and EtherTRAK I/O modules can be 
configured to respond to Modbus commands.  
 
 
OPC Servers 
The following OPC servers will respond to OPC messages from any Windows application that has an OPC client, then 
send the appropriate Modbus or SIXNET commands to the SIXNET stations and/or I/O modules: 
 

· The KepServerEx sends SIXNET protocol over Ethernet and serial ports. A limited version (32 I/O points 
total) of this server is provided free of charge on the SIXNET CD, and works with SIXNET hardware 
only. A fully featured version of this OPC server may be purchased from Kepware Products. 

· The KEPServer sends Modbus protocol over Ethernet and serial ports. This server is provided free of 
charge on the SIXNET CD, and works with SIXNET hardware only.  

 
 
DDE Servers 
The following DDE servers will respond to DDE messages from Windows database and spreadsheet programs such as 
Excel or Lotus, or from many SCADA and MMI packages such as Wonderware. The DDE server will then send the 
appropriate commands (Modbus or SIXNET) to the SIXNET stations, I/O modules or I/O database to read / write the 
desired I/O.  
 

· The KepServerEx sends SIXNET protocol over Ethernet and serial ports. A limited version (32 I/O points 
total) of this server is provided free of charge on the SIXNET CD, and works with SIXNET hardware 
only. A fully featured version of this server may be purchased from Kepware Products. 

· The KEPServer sends Modbus protocol over Ethernet and serial ports. This server is provided free of 
charge on the SIXNET CD, and works with SIXNET hardware only.  

 
 
Write Your Own I/O Driver to Send SIXNET Protocol 
Many applications can be written to send SIXNET commands directly over Ethernet and serial ports. A SIXNET 
Universal Driver Development Kit has been provided on the SIXNET CD for this purpose. This kit contains detailed 
information on the SIXNET Universal protocol. To install the SIXNET Universal Driver Development kit, access the 
“Install Software” link on the SIXNET CD.  
 
 
Creating an IOmap Configuration 
There are a number of Windows applications that can use the Control Room IOmap as I/O driver. These include: 

· Citect 
· Intellution Fix 
· Programs that communicate using DDE messaging 
· Programs that communicate using OPC messaging 

 
The Control Room IOmap is a shared resource database that allows Windows applications to share data with SIXNET 
I/O. This utility establishes an I/O database in your computer’s memory. Any combination of DDE, OPC and direct 
DLL messages can then be used to read and write your I/O. 
 
If you will be running a Windows application that requires the Control Room IOmap, you will need to create or update 
an IOmap Interface. An Auto IOmap feature will automatically create an IOmap for you. To start the Autoload feature, 
select Tools -> Run Auto IOmap. 



 
Auto IOmap (I/O Tool Kit) 
The I/O Tool Kit program has an Autoload feature. When launched, the Autoload wizard will guide you through the 
creation of an IOmap configuration called Auto_IOmap. You will be able to select the stations and I/O modules to be 
included in this Auto_IOmap configuration. To start the Autoload feature, select Tools -> Run Auto IOmap. 
 
The “Auto_Iomap” configuration is saved in the project file and can be easily modified or updated at a later time.  
 
Usage 
Use the Auto IOmap feature if the Control Room IOmap will communicate with SIXNET I/O directly over Ethernet, 
serial ports, or through a SIXNET station running passthru mode.



Step 10: Exporting Tag Names to Other Applications 
 
The I/O and module tag names you create in the I/O Tool Kit are stored in your project (.6pj) file. Using the exporting 
capability in the optional SCS feature set of the I/O Tool Kit, your tag names can become readily available to many 
Windows applications. These include: 
 
ISaGRAF IEC 1131 programming 
This export is highly recommended for applications where an ISaGRAF program will be running in a SIXNET station. 
See Exporting Tag Names to ISaGRAF for more information. 
 
Follow these steps to export tag names to ISaGRAF: 

1. If you don’t already have an ISaGRAF project, run ISaGRAF and create a new one. The new project does 
not have to contain any programming. 

2. In the I/O Tool Kit, select File -> Export -> ISaGRAF. 
3. Choose your ISaGRAF project. 
4. Choose the "Only One Station" or "Selected Tags" option when you will be running an ISaGRAF program 

in a SIXNET station. 
5. Choose the “All I/O in IOmap” option if you will be running an ISaGRAF program as a Windows 

application (ISaRun). Make sure the appropriate IOmap configuration is loaded and running in your 
computer’s memory. 

 
Notes: 

1. This export feature requires that you have a license for the “SCS” feature set of the I/O Tool Kit. 
2. The ISaGRAF export option creates Input variables and Output variables in the ISaGRAF Dictionary, and 

makes the necessary “I/O Connections”. One variable will be created for each physical input / output or 
virtual input / output. 

3. If you have ISaGRAF program variables that need to be accessible outside of the ISaGRAFprogram, copy 
those variables into SIXNET virtual I/O registers.  Refer to Controlling PID Operational Parameters From 
a Windows Application for an example of how to externally control the tuning parameters of a PID block. 

4. Station prefixes (if defined) will be included with the "All I/O in IOmap" and "All Tags" choices only. 
5. Any Internal variables you create within ISaGRAF will be untouched by this export feature. 
6. The "Selected Tags" option will remove all Input and Output variables from your ISaGRAF project and 

replace them with the tags you select in the Tag Selection window. If you are re-exporting to ISaGRAF for 
the purpose of adding some new variables to your ISaGRAF project, make sure you select the original tags 
plus your new tags in the Tag Selection window.  

 
 
Citect 
There are two export functions: “SxDirect Driver” and “IOmap Interface”. Use the SxDirect Driver export for Citect 
projects that use the built-in SIXNET driver. (This is the preferable driver for most Citect / SIXNET systems.) Use the 
IOmap Interface export for Citect projects that use the SIXNET Control Room IOmap as the I/O driver. Both of these 
exports will create Variable Tag records (including analog scaling), and will also configure the appropriate Boards, 
Ports and I/O Device forms for the station(s) you export. See Exporting Tag Names to Citect for more information. 
 
NOTE: Do not run Citect’s Express Wizard Setup if you use either of the SIXNET exports to Citect. 
 
The optional SCS feature set of the I/O Tool Kit has an enhanced export function that automatically creates Variable 
Tag records containing the tag names you previously assigned. It also configures the appropriate I/O devices in your 
Citect project. 
 
Follow these steps for automatic tag record creation and I/O device configuration in your Citect project: 
 

1. If you don't already have an existing Citect project, run the Citect Explorer and create a new project. Exit 
(or minimize) the Citect Explorer. 
 
Note: It is not necessary to run the Express Wizard for SIXNET I/O. I/O device configuration will be performed 
automatically in an upcoming step.  
 

2. Use the SIXNET I/O Tool Kit to configure your SIXNET I/O. It is recommended that you assign a tag name 
to each I/O register in your system. These tag names will easily be exported to your Citect project, saving valuable 
project development time. 
 



3. Choose the Ethernet or serial port that Citect will use to communicate with the I/O. Run the Test I/O utility 
and verify that you can read/write your I/O. 
 

4. From the File menu, select File à Export I/O Definitions to -> Citect (SxDirect Driver). This export feature 
will automatically configure Citect for your SIXNET I/O and create Variable Tag records in Citect. Exit the SIXNET 
I/O Tool Kit. 
 

5. In Citect, open your project. Select File -> Pack. 
 
Citect - SIXNET configuration is now complete. If you assigned tag names in the SIXNET I/O Tool Kit, they will now 
be available in the Citect Graphics Builder. If you didn't assign tag names, select Tags -> Variable tags and create the 
necessary Variable Tag records. Alternatively, you can run the SIXNET I/O Tool Kit and assign tag names, then repeat 
steps 4 and 5. 
 
Intellution Fix.  
The tag records in the .GDB file will contain I/O tag names and analog I/O scaling values from the I/O configuration 
file. See Exporting Tag Names to Intellution for more information. 
  
CSV file  
Use this export for spreadsheet applications that can import comma separated variable (.csv) files. The tag records in 
the .csv file will contain I/O tag names and analog I/O scaling values from the I/O configuration file. Refer to CSV 
Export File Format for an example of a CSV file.  
 
Modbus OPC (Kep Server) 
Use this export for OPC-based applications where Modbus RTU is the desired protocol to send to the SIXNET 
hardware. The Kepware server sends Modbus RTU protocol over Ethernet and/or serial ports to communicate with I/O. 
Note that in RS232 and RS485 applications the SIXNET serial port must be configured for the “Modbus RTU Slave” 
mode in order for the Kep Server to communicate properly. This is not an issue with Ethernet communications because 
SIXNET Ethernet ports respond to SIXNET protocol and/or Modbus protocol automatically. 
 
KepServerEx 
Use this export for OPC-based applications where SIXNET is the desired protocol to send to the SIXNET hardware. 
The KepServerEx sends SIXNET protocol over Ethernet and/or serial ports to communicate with I/O. In RS232 and 
RS485 applications the KepServerEx is preferable over the Kep Server. Because the KepServerEx sends SIXNET 
protocol, the SIXNET serial port does not have to be reconfigured before SIXNET operations can be performed. Note 
that this is not an issue with Ethernet communications because SIXNET Ethernet ports respond to SIXNET protocol 
and/or Modbus protocol automatically. 
 
By exporting tags to your Windows applications, you can reduce or eliminate the need to create and maintain tag names 
within your different programs.  
 
The “Connected To:” field for each station ultimately determines which applications a station’s tag names can be 
exported to. This information is listed in the help topics for each export window. 
 
Select File -> Export -> (appropriate application) to export a station’s tag names. 
 


